Partial site outage
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 06, 2018 - 10:32 EST
Investigating
Some folks may not be able to access parts of Kickstarter.com. We're working to resolve this issue as quickly as possible. Apologies for any inconvenience!
Posted 10 months ago. Feb 06, 2018 - 10:03 EST