Kickstarter site down
Incident Report for Kickstarter
Resolved
This issue has been resolved, and we're keeping an eye on site performance to make sure everything is working smoothly. Please stay tuned for the all-clear.
Posted Jul 05, 2023 - 19:36 EDT
Investigating
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Jul 05, 2023 - 19:27 EDT
Identified
We've identified the cause of this issue and are working to release a fix as soon as possible. Thanks for your patience!
Posted Jul 05, 2023 - 19:08 EDT
Investigating
We're working to resolve this issue as quickly as possible. Apologies for any inconvenience!
Posted Jul 05, 2023 - 18:51 EDT
This incident affected: Kickstarter.com, Payments, and Mobile.