Creator Payouts not processing for some campaigns
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 12:13 EDT
Monitoring
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted Sep 26, 2022 - 15:17 EDT
Update
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted Sep 26, 2022 - 15:16 EDT
Investigating
We've identified the cause of this issue and are working to resolve as soon as possible. Thanks for your patience!
Posted Sep 26, 2022 - 11:48 EDT
This incident affected: Payments.