Issues with pledging
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 4 months ago. Dec 01, 2016 - 17:14 EDT
Monitoring
Pledging is functioning normally, but kickstarter.com/recommendations is down. Thanks for bearing with us!
Posted 4 months ago. Dec 01, 2016 - 17:01 EDT
Investigating
We've detected errors with pledging and we're working on a fix. Thanks for your patience!
Posted 4 months ago. Dec 01, 2016 - 16:06 EDT