Issue with certification warnings
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the situation and everything looks good. Sorry for any trouble.
Posted 5 months ago. Oct 13, 2016 - 23:54 EDT
Identified
We've identified the cause of this issue and are working to release a fix as soon as possible. Thanks for your patience!
Posted 5 months ago. Oct 13, 2016 - 11:53 EDT