Site is down
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 31, 2017 - 11:58 EDT
Monitoring
The site is back up. We're monitoring closely to make sure it stays up.
Posted about 2 months ago. Jan 31, 2017 - 11:43 EDT
Identified
Our developers are actively working on getting the site back up. Thanks for your patience!
Posted about 2 months ago. Jan 31, 2017 - 11:32 EDT