Inaccurate pledge amounts reflected on project pages and dashboards

Incident Report for Kickstarter

Resolved

This incident has been resolved.
Posted Nov 22, 2019 - 17:46 EST

Update

A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted Nov 22, 2019 - 17:46 EST

Investigating

We are currently investigating this issue.
Posted Nov 22, 2019 - 15:39 EST
This incident affected: Kickstarter.com.