Intermittent issues across the site
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Sep 13, 2024 - 15:39 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2024 - 14:53 EDT
Investigating
We are currently investigating this issue.
Posted Sep 13, 2024 - 13:37 EDT
This incident affected: Payments.