Issues uploading and viewing videos, images, and audio files
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 14, 2017 - 16:16 EDT
Identified
We're currently experiencing an issue around uploading image, video, and audio assets. We're on it!
Posted about 1 year ago. Sep 14, 2017 - 15:07 EDT