Slow site performance
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted over 3 years ago. Jun 16, 2015 - 02:14 EDT
Monitoring
Site performance is back up to speed. Our developers are still monitoring to make sure everything continues to run smoothly. Thanks for your patience!
Posted over 3 years ago. Jun 15, 2015 - 22:59 EDT
Update
We're hard at work to resolve the issue. In the meantime, if you have made a pledge to Shenmue 3, you may not see your pledge reflected on the project page right away.
Posted over 3 years ago. Jun 15, 2015 - 22:12 EDT
Investigating
Due to a sudden increase in site traffic, we're experiencing slow performance on the site. Our developers are working hard to resolve this as quickly as possible.
Posted over 3 years ago. Jun 15, 2015 - 21:57 EDT