Radio buttons broken across creator experiences.
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Aug 26, 2024 - 14:11 EDT
Monitoring
A fix has been implemented and we're standing by to make sure everything runs smoothly.
Posted Aug 26, 2024 - 14:06 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 26, 2024 - 13:43 EDT
Investigating
We've identified an issue with radio buttons across various creator experiences. Thanks for your patience while we look into this!
Posted Aug 26, 2024 - 13:27 EDT
This incident affected: Kickstarter.com.