Issue with "Load More" on Discover pages
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 02, 2019 - 23:05 EST
Investigating
Our developers are currently investigating an issue with the "Load More" button on Discover pages. At this time, it's not possible to load additional results. Thanks for your patience while we look into this!
Posted 8 months ago. Jan 02, 2019 - 21:49 EST
This incident affected: Kickstarter.com.