Email Deliverability

Incident Report for Kickstarter

Resolved

This incident has been resolved.
Posted Nov 23, 2020 - 16:43 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 23, 2020 - 14:41 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 23, 2020 - 14:35 EST

Investigating

Currently we are experiencing issues delivering emails to our users. Kickstarter is aware of this issue and is working to resolve. Thanks for your patience while we look into this!
Posted Nov 23, 2020 - 12:23 EST
This incident affected: Kickstarter.com and Mobile.