Creators unable to save changes to the "Payments" tab of Project Build
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 20 days ago. Oct 31, 2018 - 20:21 EDT
Investigating
We are currently investigating this issue.
Posted 20 days ago. Oct 31, 2018 - 15:35 EDT
This incident affected: Kickstarter.com.