Advanced Creator Dashboard Not Loading

Incident Report for Kickstarter

Resolved

All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted Oct 20, 2025 - 19:12 EDT

Monitoring

Our Advanced Creator Dashboard pages should now be loading correctly. We will continue to monitor this over the next hour. Thanks for your patience!
Posted Oct 20, 2025 - 18:11 EDT

Identified

We're currently experiencing an issue with our Advanced Creator Dashboard pages, which are not loading. We're on it!
Posted Oct 20, 2025 - 13:38 EDT
This incident affected: Kickstarter.com.