Issue affecting the upload of videos and other assets
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 11 months ago. Jan 10, 2017 - 17:49 EST
Investigating
Our developers are currently investigating an issue affecting the upload of videos and other assets. Thanks for your patience while we look into this!
Posted 11 months ago. Jan 10, 2017 - 16:17 EST