Most videos not loading
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 7 months ago. May 25, 2018 - 22:35 EDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. May 25, 2018 - 22:03 EDT
This incident affected: Kickstarter.com, Mobile, and Drip.