Creators unable to submit and launch projects
Incident Report for Kickstarter
Resolved
All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted 2 months ago. May 10, 2019 - 18:26 EDT
Identified
Submitting and launching projects isn’t working. The issue has been identified and we’re working on a fix.
Posted 2 months ago. May 10, 2019 - 17:27 EDT
This incident affected: Kickstarter.com.