Increased declines for Visa authorizations
Incident Report for Kickstarter
Resolved
This incident has been resolved.
Posted 11 months ago. Jun 02, 2018 - 10:15 EDT
Investigating
Our upstream payment provider is reporting increased declines for Visa authorizations. We’re monitoring the situation and will post updates as we learn more.
Posted 11 months ago. Jun 01, 2018 - 12:54 EDT
This incident affected: Payments.